Fix: Teams App Registration Compatibility Error

Issue 

When opening the Enterprise for MS Teams app, you may see an error message on the first screen that says:

⚠️ Connection Error

Unable to connect to Enterprise Service Management (M42) due to app registration upgrade.
Please contact your system administrator to follow the steps in the documentation to fix the connection.
<Open documentation here>
ESM URL:
https://<customer.esm.platform.net>

 

Cause 

The app registration for the Teams integration has been updated to follow Microsoft publishing policies.
Older versions of the app are not compatible with the new registration.

Resolution

System administrators can resolve this issue by re-registering the application integration and agreeing to the required permissions.

Verification 

In Microsoft Teams, open the Enterprise for MS Teams app.
The app should now open correctly and land on the Self Service Portal page without errors.
 

 

 
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